How to I prevent <X> from being treated as a placeholder in the UI?

Is there a way to translate command line help strings in the Transifex editor without having to switch to raw mode?

Example string:

https://www.transifex.com/widelands/widelands/translate/#es/widelands/40084697

/kick <name> <reason>  -  Kick the user <name> because of <reason>

Translation:

/kick <nombre> <razón>  -  Expulsar al usuario <nombre> por <razón>

I’d like to make this setting on a project or organization-level, so my translators won’t get confused again. We are using other placeholder formats (e.g. %1$s or %1%), and we do want these displayed as placeholders.

Hello @gunchleoc,

Thank you for your question.

These are handled by default as HTML code. This has nothing to do with the placeholders you have already added. If I have understood correctly what you want is a way to display this text as translatable text. Now you need to switch to raw mode to translate it. Is that correct?

Text like are automatically detected as HTML so there are 2 options:

  • Either switch to raw mode as you do already
  • Or change the format of this text in the original file (source file)

According to the second option in order to be clear to you I mean to keep the PO file but change if it is feasible the format instead of to something different that our parser will not treat it as HTML code.

I am waiting for your response.

Kind regards,
Panagiotis

Thanks four your reply!

Not an option. I know how to do it, but the problem is translation mistakes by others.

Not an option. The translation UI should not force us to depart from established standards on how to display command line help to users.

Could you please add an option for project maintainers to turn that off?

Hello @gunchleoc,

Thank you for your response.
I would like to inform you that I will share your feedback with our team in order to take it into consideration for future improvements. I will inform you once I have an update on this.

Thank you in advance.

1 Like

Hello @gunchleoc, another way to display command line help to users is to escape the signs with HTML entities. To the best of my knowledge several documentation and WYSIWYG editors out there share the same problem and use this trick.
So instead of typing <X> you can type &lt;X&gt;. This way Transifex editor will also be protecting the HTML entities for &lt; and &gt;

I had to escape signs in the editor of this post to type the suggested examples. When I wrote the actual signs the editor detected <X> as an HTML elements and did not render it properly.
Here is what I actually wrote in the WYSIWYG editor:
So instead of typing &lt;X&gt; you can type &amp;lt;X&amp;gt;. This way Transifex editor will also be protecting the HTML entities for &amp;lt; and &amp;gt;

That’s going to be an illegible pain in offline editors though. I don’t want to deprive people of their tool of choice just because Transifex is in the mix.

Also, I don’t want to make people retranslate all those strings.

Personally, I do most of my translation in MemoQ with additional support from Transifex features on top of that, and other people will be using Virtaal or Poedit or Trados or some other offline tool.