0 untranslated is wrong

It happens in a very specific case where I’ve omitted the placeholder in a translation and then after I saw the error I’ve fixed it and saved.

1 Like

Hello Yaron,

Thank you for contacting Transifex support.

Could you please share with us more details about the issue, in order to understand better your scenario? Maybe an example with detail steps it would be more than helpful.

Kind regards,

Hi Yaron,

Follow up my previous reply, I think that I understood your issue. I will share this with our dev-team and I will inform you as soon as possible.

Thank you in advance.

Hello Yaron,

Follow up my previous replies, could you please describe step by step how you are getting this error? Because I tried with your example and I am getting the following images.

Thank you in advance.

Sure, all you need is a project that has plural forms with parameters and validity checks (so you won’t be able to delete the parameter) and go to the strings and omit the parameter from one of the forms and save it, you will see an error but the number of untranslated string will decrease regardless.

Thank you Yaron for your quick response.

After my investigation on the same file I couldn’t achieve to reproduce this error. Here is the following image

As you can see for the plural form 1 I omitted to include the variable 1%d and I pushed the save button, but even if I have the following Translation check
as an error or as a Warning, the Untranslated TAB count remains the same.

So, could you please provide a specific example with the necessary steps, the translations checks for the specific file format, the resource etc. in order to reproduce this?

Thank you in advance.

Yet again:

My explanation wasn’t good enough, sorry, I’ll start fresh:

  1. Make sure that the project is enforcing preservation of variable substitution (so far so good).
  2. Remove a variable from one of the forms
  3. Save and observe the error
  4. Go back to the string you removed the variable from
  5. Add the variable back
  6. Save the string

Please share your conclusions on this :slight_smile:

EDIT: Please pay attention to the other important bug - Dark Mode is not preserved between sessions.

Hello @yaron,

I would like to inform you that we resolved the issue you mentioned.
Please let me know if you have further questions on this.

Have a nice day!