Developer comments not escaped in Structured JSON (translator mode)

Hello!

I’m noticing that when I download Structured JSON using translator mode, developer comments are not escaped for JSON. That is, developer comments seem to be included as-is without any escaping. This results in invalid JSON that I cannot use in my application. I see this both when I download the JSON using the client and when I download it from the Transifex website in a browser.

I believe that the translations are still being escaped. That is, the value of the string property seems to be escaped. However, the value of the developer_comment property is not escaped.

Thank you, and please let me know if I can provide any additional information!

Hello Matthew,

Thanks for reaching out to Transifex support.
I tried to reproduced the scenario you mentioned without any luck, Let me give you a little bit more context on what I did.
This is how my original file looks like, As you can see, here I scaped the quotes with a single back slash before each quote:

Now, To download the file I used API v3 using the following endpoints.
To create a download action: “https://rest.api.transifex.com/resource_translations_async_downloads
and to get the content “https://rest.api.transifex.com/resource_translations_async_downloads/{resource_translations_async_download_id}
As you can see on the following image I set the request in translator mode:


And this is how the response looks:

Please let me know if Im missing something.

Best Regards
Cesar

“developer_comment”: "This is a pluralized string with special character & “test” with quotes ",

Hi @Cesar_Garcia! Thank you for looking into this. I tried what you suggested, and I do see that when I download translations using the API, developer comments are escaped.

However, the resulting download is structured very differently from the translations I have downloaded in the past. For example, the object is flat (there is no nesting), and plural strings do not use ICU plurals and are instead objects.

When I download translations from the Transifex website, they match the structure I expect. To do so, I navigate to my resource, click a language, then click “Download file to translate”. However, in this format, developer comments are not escaped. I see the same thing when I run tx pull using the Transifex Client.

Are you able to reproduce this behavior if you use the Transifex website or the Transifex Client?

Thank you again for your assistance!

Legal platformsPreformatted textLegal all websites networks search console setting services servers hosting html bb code ssl vpn url dns wi-fi tls s/mime smtp popup mdm api faq seo sdk http/https other program products trobleshooter

Summary

This text will be hidden

mail gmail Outlook Spark AirmailApp boxes books e-books pages links paper document licenses community transleter langueges and all platforms websites networks Legal public and Original.