Help with Autofill

Hi everybody. My name is Daniel Merino and I write this as manager of the spanish and basque translation of the Sakai Project (, an open source LMS from Apereo Foundation.

The project in Transifex has this URL:

We have a translation process that synchronizes the translations existing in Github source code with Transifex using some python scripts that make use of Transifex client.

Our translators work in Transifex and, from time to time, we create a patch and merge it in Github so the translations are applied.

Our issue is that, every time a developer moves a folder to another place in the source code, the old strings are removed from Transifex and new strings are created in the new place, so our translators need to rework on them.

The last movement have been the properties of the Assignment tool’s folder, which have changed their placement. ( We have gone from a 100% translation to a 0.65%.

After these changes, we use the Transifex client to update the strings, making an upload of the new folder. We have done this with the spanish translation, which is already at 98%.

However, I have learned that your Autofill feature could automatically translate the keys with 100% match. Every moved string in source code has a 100% match in the suggestions, so we would like to enable this feature so we can save work.

I have enabled it after the last folder move but still the basque and catalan translations have not been automatically translated and they are at 0.65%, though all the strings have a 100% match in the suggestions.

I wonder if this is caused because we enabled the autofill after the folder move? And if this is the cause, how could we launch the autofill for the current folders?

I hope to have been clear about our issue, please don’t hesitate in asking me anything you need to know.

Thanks in advance and best regards.

Hello Daniel,

Thank you for contacting Transifex support.

Regarding your case, I further looked into this and found out that under your project’s settings page, the option “Translation Memory Context Matching” has been enabled:


This means that except for text match, context match is also required in order for an untranslated string to automatically be translated by TM. More information about how this feature works can be found in our documentation guide here.

For example, the following string (#11) has a 100% TM suggestion available. However, since the setting “Translation Memory Context Matching” is enabled, the system does not automatically translate the string (no context match was found). If context match was detected too, then 101% match would be available as it is described in the documentation link I shared above.


If you would like TM to automatically translate strings taking only text matches into account, then you need to disable the setting from your project’s settings page.

I hope that the above helps.

If you need any additional clarification, please let me know.

Kind regards,

Hi Panagiotis,

I have disabled the option “Translation Memory Context Matching” as you have pointed.

I still see the basque translation of Assignment tool at 0.65%. For example, in the 922 untranslated strings, the number #13 has a 100% match that has not been applied.

Other strings have two 100% matches, I think that the newest suggestion should be applied in these cases.

Do we need to make any extra step to automatically apply translation of the translation memory 100% matches? Or should we just wait?

Thanks for your help.

Hello Daniel,

Regarding your case, I looked into your project “sakai-trunk” and found that the percentages for these 2 languages (Basque,Catalan) are 95,48% and 99,78% each one, as you can see in the following image.

So, are you referring to this project or for another one?

If you need any further assistance, please let me know.

Kind regards,