API token not found. Please provide it and it will be saved in '~/.transifexrc'

I have a script that should regularly pull translations from Tx to repo. I wrote “should” because it doesn’t output same results whether run as a github action or locally. But this is a side issue.

That script used to work and worked even last week both as a github action and from a local call. I tried it again yesterday and it started to fail:

  • in local (I’m not on the computer right now but something like): 401 Unauthorized: invalid token. I tried to tx pull locally and have the pull aborted as soon as it started. But I can run another script to fetch statistics from the project on Transifex, using the token.
  • the github action returns: API token not found. Please provide it and it will be saved in '~/.transifexrc'.
    I regenerate the token from Transifex, replace it in the repo settings, rerun and keep getting the same message. See Pull translations · qgis/QGIS-Documentation@6946583 · GitHub

Any hints, please? I’m available for any more details.

Hello DelazJ,

Are you using the CLI? Could you please share your .tx/config file and the content of your .transifexrc file(without your token)? Is your valid token there?


Hello Sandy.
Good catch :wink:
I inspected once again my files and spotted an issue in my .tx/config file using

host = https://www.transifex.com

instead of

host = https://app.transifex.com

I launched again my action and it passed the token level and is currently trying to pull files on Tx. So all good now.
Thanks again.

1 Like