Github integration: 100% translated language not pushed to Github

Hello,

Here is my project and Github repo, with the related yaml configuration:

filters:
  - filter_type: file
    # all supported i18n types: https://docs.transifex.com/formats
    file_format: PO
    source_language: en
    source_file: usr/share/oma-welcome/om-welcome.pot
    # path expression to translation files, must contain <lang> placeholder
    translation_files_expression: po/<lang>.po
settings:
  language_mapping:
    en: en_US
    fr: fr_FR
    it: it_IT

Yesterday evening someone translated the serbian language fully (100%), but sr.po was not pushed to Github. I don’t know how to troubleshoot or how long I have to wait for next sync. I tried to create again the Tx/github link but it was not pushed neither.

What did I do wrong?

Hello

The translation_files_expression needs to be encapsulated in single quotes.

By making this or any change in the YAML config file you will trigger a sync. As an added step you may consider removing a single translation, save and then put it back in, in order to trigger the sync.

Please let us know if this solves the issue.

Kind Regards,

1 Like

Thank you @anthonydim indeed it works, with the quotes. I also had to suppress a string, translate it again, to trigger the push.

1 Like

Hi,

We are also facing problems with github integration for an Android project. The translations are being updated in transifex as expected, but once a language is 100% it is not pushed to github. We think it has to be something in the yaml configuration:

filters:
 - filter_type: file
   source_file: app/src/main/res/values/strings.xml
   file_format: ANDROID
   source_language: en
   translation_files_expression: 'app/src/main/res/values-<lang>/strings.xml'

We tried other configurations as well, but same result. Is there anything we are missing?
Thank you!

1 Like

Hi @Balcan,

Can you please share your project URL so as to investigate this further?

If it is a private project, then please reach out to us at support@transifex.com so that we can take a better look at it.

Thanks,
Nina

1 Like

Hello,

We have the same issue. When we push resources updates to GitHub repository, transifex gets it well. But when we get 100% translations and have 100% reviewed there is no expected commit or PR with translations to GitHub. Does my YAML config look well?

filters:
- filter_type: file
  file_format: YML
  source_file: config/locales/common.en.yml
  source_language: en
  translation_files_expression: 'config/locales/common.<lang>.yml'

- filter_type: file
  file_format: YML
  source_file: config/locales/annual_payments.en.yml
  source_language: en
  translation_files_expression: 'config/locales/annual_payments.<lang>.yml'

- filter_type: file
  file_format: YML
  source_file: config/locales/api.en.yml
  source_language: en
  translation_files_expression: 'config/locales/api.<lang>.yml'

@Balcan, have you solved your issue?

Thank you.

@ASergey can you please let me know if the user who installed the app in your organization is the same as the one who actually connected the GitHub repository to the specific project in Transifex? If not, then, in this case, the same user should do both in order this to work properly. So, I would suggest you:

  • Unlink the project with GitHub via your project’s settings page
    (please keep a copy of your YML configuration file in order to be easier for you to add this back)
  • Ask the user who installed the app in the organization to link the project with the GitHub repository again

Please let me know if the above helps.

Regards,
Nina

Thank you very much, @nina ! You’ve helped a lot :smiley:
We’ve reconnected GitHub repository to Transifex with one user and synchronization got working.

1 Like