Updating STRUCTURED Json schema prop is not reflecting in existing translation

Hi, I am facing a weird issue.
I am using STRCUTRUED Json Schema for my project. I have started with two properties
{
“key1”:{
“string”:“Sample”,
“context”:“This is simple context”
},
“key2”:{
“string”:“Sample”,
“context”:“This is simple context”
}
}

I have onboarded translators and every thing is working fine.

Now I have recently introduced another property in my source language json file called “character_limit”

{
“key1”:{
“string”:“Sample”,
“context”:“This is simple context”,
“character_limit”:20
},
“key2”:{
“string”:“Sample”,
“context”:“This is simple context”,
“character_limit”:20
}
}

But this is not reflecting on the portal page where translators can translate text. I still see the Character Limit is set to 0 no limits are being applied But If I add a brand new resource file from the scratch then it takes the latest schema.

How do I make an update with out dropping existing Translations.

Thanks
Pavan

@nina @Panagiotis_Kavrakis Can you please shed some light on how to work with this one

Hello @pavan.josyula

Thank you for reaching out to our Community.

Let me present to you my investigation according to your issue, and please let me know if I did something different than your scenario.
I uploaded a Key-Value JSON sample file in a test project of mine using the Key-Value JSON parser. What was actually happened was to have the following image in my application

Then I updated the same file adding the tag character_limit:20 as in your example. Below is the updated part in my file.
image
What was the final result after the update? Nothing different than the first image in my reply.

Moreover, I uploaded the same file with the character_limit as a new source file, and as you can see either this time my file recognized the character_limit:20. below is the image of the same file as a new source file.

So, could you please confirm if the previous actions apply to your issue’s description?

Thank you in advance for your response.

Yes, this is what I see @Panagiotis_Kavrakis.
To make character_limit effective i would either need to delete all the existing translations and update the source language file or add as new resource.

Thanks
Pavan

Hello @pavan.josyula

Thank you for your confirmation.

Since I couldn’t reproduce your issue to make character_limit effective, could you please share your initial file and the second version of your file, in order to investigate further your issue?

Kind regards,
Panagiotis

@Panagiotis_Kavrakis

Original Json
{
“A”: {
“O”: {
“string”: “Basket approved by approver”,
“context”: “Basket approved by approver” ,
“developer_comment”:“This is my test developer comment”
},
“P”: {
“string”: “Payment approved by approver”,
“context”: “Payment approved by approver”
}
},
“D”: {
“O”: {
“string”: “Basket declined by approver”,
“context”: “Basket declined by approver”
},
“P”: {
“string”: “Payment declined by approver”,
“context”: “Payment declined by approver”
}
},
“E”: {
“O”: {
“string”: “Approval timeout escalation actioned”,
“context”: “Approval timeout escalation actioned”
},
“P”: {
“string”: “Approval timeout escalation actioned”,
“context”: “Approval timeout escalation actioned”
}
},
“L”: {
“O”: {
“string”: “Basket locked for editing”,
“context”: “Basket locked for editing”
}
},
“M”: {
“O”: {
“string”: “Basket modified by approver”,
“context”: “Basket modified by approver”
}
},
“O”: {
“O”: {
“string”: “Order created from approved basket”,
“context”: “Order created from approved basket”
}
},
“R”: {
“O”: {
“string”: “Approval reminder actioned”,
“context”: “Approval reminder actioned”
},
“P”: {
“string”: “Approval reminder actioned”,
“context”: “Approval reminder actioned”
}
},
“S”: {
“O”: {
“string”: “Basket submitted for approval”,
“context”: “Basket submitted for approval”
},
“P”: {
“string”: “Payment submitted for approval”,
“context”: “Payment submitted for approval”
}
},
“U”: {
“O”: {
“string”: “Basket unlocked”,
“context”: “Basket unlocked”
}
}
}

JSON with Char limit
{
“A”: {
“O”: {
“string”: “Basket approved by approver”,
“context”: “Basket approved by approver”,
“character_limit”:50,
“developer_comment”:“This is my test developer comment”
},
“P”: {
“string”: “Payment approved by approver”,
“context”: “Payment approved by approver”,
“character_limit”:50
}
},
“D”: {
“O”: {
“string”: “Basket declined by approver”,
“context”: “Basket declined by approver”,
“character_limit”:50
},
“P”: {
“string”: “Payment declined by approver”,
“context”: “Payment declined by approver”,
“character_limit”:50
}
},
“E”: {
“O”: {
“string”: “Approval timeout escalation actioned”,
“context”: “Approval timeout escalation actioned”,
“character_limit”:50
},
“P”: {
“string”: “Approval timeout escalation actioned”,
“context”: “Approval timeout escalation actioned”,
“character_limit”:50
}
},
“L”: {
“O”: {
“string”: “Basket locked for editing”,
“context”: “Basket locked for editing”,
“character_limit”:50
}
},
“M”: {
“O”: {
“string”: “Basket modified by approver”,
“context”: “Basket modified by approver”,
“character_limit”:50
}
},
“O”: {
“O”: {
“string”: “Order created from approved basket”,
“context”: “Order created from approved basket”,
“character_limit”:50
}
},
“R”: {
“O”: {
“string”: “Approval reminder actioned”,
“context”: “Approval reminder actioned”,
“character_limit”:50
},
“P”: {
“string”: “Approval reminder actioned”,
“context”: “Approval reminder actioned”,
“character_limit”:50
}
},
“S”: {
“O”: {
“string”: “Basket submitted for approval”,
“context”: “Basket submitted for approval”,
“character_limit”:50
},
“P”: {
“string”: “Payment submitted for approval”,
“context”: “Payment submitted for approval”,
“character_limit”:50
}
},
“U”: {
“O”: {
“string”: “Basket unlocked”,
“context”: “Basket unlocked”,
“character_limit”:50
}
}
}

Please find the attachments![Add Resource With Original_en|690x466]

(upload://d5gGbZIeY5i9HYFzfgskiS8vYRy.png) Afterupdating_Source_WithCharlimit_json No Charlimit is set

Hello @pavan.josyula ,

Thank you for sharing your files.
Indeed I reproduced your issue, and I have forwarded it to our development team. Once I have an update I will let you know.

In the meantime, you could enable the TM-auto fillup in order when you upload the resource as a new file the translations will be completed from the previous resource automatically.

Thank you in advance for your patience and cooperation.

Kind regards,
Panagiotis

Thank you I will check that option