Error after migrating to TX Client, version=1.1.0

Hi,
I didn’t use the tx Client for a long time and since my old installation didn’t work anymore, I’m trying to configure the new version. Looked like the ‘tx migrate’ worked. I’ve tried to adjust the section headers in my config file to the new format [o:org_slug:p:project_slug:r:resource_slug]. However, when I initiate a pull command (for the virtuemart project, the client comes up with an error message (see below). I can’t figure out what I did wrong. Any ideas?

C:\svntx>tx --v
TX Client, version=1.1.0

C:\svntx>tx pull --a

# ?[1;33mResource o:virtuemart:p:virtuemartplugins:r:vm-admin-plg_vmpayment_mone
ybookers?[0m

?[30;101m  ERROR  ?[0m ?[91mFetching project 'virtuemartplugins': Get "/projects
/o:virtuemart:p:virtuemartplugins": unsupported protocol scheme ""?[0m
?[96m¯ ?[0m ?[97mFetching project 'virtuemartplugins'?[0mGet "/projects/o:virtue
mart:p:virtuemartplugins": unsupported protocol scheme ""

An example from my old config:

[virtuemart.vm-admin-com_virtuemart]
file_filter = translations/administrator/language/<lang>/<lang>.com_virtuemart.ini
source_file = translations/administrator/language/en-GB/en-GB.com_virtuemart.ini
source_lang = en_GB
type = INI

An example of my new config (not working):

[o:virtuemart:p:virtuemart:r:vm-admin-com_virtuemart]
file_filter = translations/administrator/language//.com_virtuemart.ini
source_file = translations/administrator/language/en-GB/en-GB.com_virtuemart.ini
source_lang = en_GB
type = INI

Hello jjk,

I am Antonis, a support engineer from the Transifex support team.

I see 2 possible issues that might cause this.

Firstly, the newest version of the client is v1.3.1 which I would recommend downloading to make sure any issues are not caused by already resolved bugs.

Secondly, while the updated slugs look correct I noticed that the file filter is missing the <lang> tags:

Old file filter: file_filter = translations/administrator/language/<lang>/<lang>.com_virtuemart.ini
New file filter: file_filter = file_filter = translations/administrator/language//.com_virtuemart.ini

This might be caused due to the website omitting them but I’m just making sure.

Other than that I don’t see any other visible changes. Can you look into these two issues and let me know if the issue is resolved or if it persists?

Kind regards,

Antonis