Format when uploading translations

At work we use Java .properties files to store our language files. There’s one language that we couldn’t translate in-house, so we hire someone to do it. I downloaded a text file for translation, sent it, and got it back translated.

I have tried to upload the file, but even though it says it has successfully been uploaded, the strings are not present and the language stays 100% untranslated.

I noticed some differences between the .properties file and the text file I’ve got for translation. The main difference is the line comment (#), but I wonder if there are some formatting elements that have to be corrected in order for Transifex to be able to read in the translated file.

Could someone give me some pointers as to how to do this right? I’ve read this page: but I can’t make it work.


Hi @Gerardodiego,

Thank you for posting your question!

If I have understood your case correctly, your resource in Transifex is parsed by our Java Properties parser and you are trying to upload translations in a TXT format. Am I right?

If that’s the case, then unfortunately, this is not going to work because a Java Properties parser cannot recognize TXT syntax and correctly map translations to the corresponding source strings in Transifex.

Why should this translation file be in a txt format? Is there any way to convert it to a .properties format instead?

Hi Nina, thanks for your answer!

When I downloaded the “file for translation” it came as a text file, so I tried to upload it, translated, the same way and that’s what didn’t work.

As you mention correctly, I created a .properties file on my project, pasted the contents of the text files and fixed the format a bit (removed comments and corrected the comments there where they actually should be), and then used the command line client to push the resource and it worked perfectly.

So, I think that’s a way this can be done. Thanks again!


Thank you for your response.

Could you please contact our support at and share more details about the resource in your TX project as well as the file you are trying to upload to Transifex? This will help us to investigate it further and help you figure things out.


Okie, I will.

Have a sunny day.


1 Like