Special Character conflict with Transifex keyboards


#1

I am trying to add a language special character, but when using the shortcut to add the special character (like “é”), it will copy a variable from the translation, or present another action.


#2

In TX editor preferences, you can disable shortcuts to avoid your keyboard shortcut to conflicts with Transifex shortcuts.


#3

Another option is to pop up the fallback/accessibility editor, which is a simple textarea without all the helpers and functionality of the default editor.
Using this editor you can add whatever special character your keyboard supports without losing the default editor shortcuts.

To open the fallback editor use the Ctrl+q shortcut. Type whatever you want and use the same shortcut to update translation back to the default editor. Use Esc shortcut to cancel your edits in the fallback editor.